logo

Suletuxe.de
Linux - Nutzer
helfen
Linux - Nutzern

Willkommen, Gast. Bitte Login oder Registrieren.
29. November 2020, 16:18:49
Übersicht Hilfe Suche Login Registrieren

Amateurfunk Sulingen
Diskussions- und Newsboard der Linux Interessen Gruppe Suletuxe  |  allgemeine Kategorie  |  Installation & Einrichtung  |  Thema: Installation « zurück vorwärts »
Seiten: [1] 2 3 nach unten Drucken
   Autor  Thema: Installation  (Gelesen 1929 mal)
helinux
Newbie
*

Offline

Einträge: 24



Ich liebe dieses Forum!

Profil anzeigen
Installation
« am: 26. April 2020, 16:40:51 »

Hallo,
ich bin gerade dabei, Programme in Linux einzurichten.
LibreOffice habe ich installiert, alles in Ordnung.
Nur startet es nicht und bricht mit der Fehlermeldung:
"error while loading shared libraries: libicuuc.so.65"
ab. Es scheint ein Problem des Updates zu sein, doch weiß ich nicht, wie ich das beheben kann.
Vielleicht kann mir jemand eine Tipp geben.
Sonst hoffe ich, dass alle gesund sind und irgendwann, möglichst bald, wieder Treffen stattfinden können!
Helmut
Gespeichert
Andreas
Administrator
*****

Offline

Einträge: 779



Linux von Innen

Profil anzeigen
Re:Installation
« Antwort #1 am: 26. April 2020, 17:09:54 »

Hallo Helmut,

bitte schreib uns noch, was Du für ein System benutzt / wie Due es installiert hast. Also z.B. "ein Antergos mi der Live-CD, erstellt September 2019" oder "eine Neuinstallation mit der EndeavourOS-DVD vom xx.yy.zz". Das sind Infos die dringend benötigt werden für eine schnelle zielführende Hilfe.

LG
Andreas

...und bleibt alle gesund!
Gespeichert

Wissen ist das einzige Gut, das mehr wird, wenn man es teilt - wenn es Menschen gibt, die es weitergeben, und es Menschen gibt, die bereit sind, dieses Geschenk auch unter eigenem Einsatz anzunehmen.


Freiheit zu erkämpfen reicht nicht. Man muss sie auch verteidigen.
helinux
Newbie
*

Offline

Einträge: 24



Ich liebe dieses Forum!

Profil anzeigen
Re:Installation
« Antwort #2 am: 26. April 2020, 18:34:37 »

istalliert ist EndevourOS im November 2019 beim Linux-Treffen
Gespeichert
Andreas
Administrator
*****

Offline

Einträge: 779



Linux von Innen

Profil anzeigen
Re:Installation
« Antwort #3 am: 27. April 2020, 03:50:50 »

Welches Libreoffice-Paket hast Du installiert? Das "richtige" heißt libreoffice-fresh, nicht libreoffice! Ich denke Du hast letzteres installiert...

Du solltest folgende Pakete installieren:
libreoffice-fresh
libreoffice-fresh-de

Alles andere was Du zu libreoffice bereits installiert hast (und was nachgezogen wurde) solltest Du wieder entfernen. Um zu sehen was Du schon installiert hast kannst Du mit

pacman -Qs libreoffice nachschauen
sudo pacman -R <paketname> deinstalliert dann das/die Pakete. Sind es mehrere, schreibst Du die Namen einfach mit Leertaste getrennt hintereinander.

LG
Andreas
Gespeichert

Wissen ist das einzige Gut, das mehr wird, wenn man es teilt - wenn es Menschen gibt, die es weitergeben, und es Menschen gibt, die bereit sind, dieses Geschenk auch unter eigenem Einsatz anzunehmen.


Freiheit zu erkämpfen reicht nicht. Man muss sie auch verteidigen.
helinux
Newbie
*

Offline

Einträge: 24



Ich liebe dieses Forum!

Profil anzeigen
Re:Installation
« Antwort #4 am: 27. April 2020, 09:34:29 »

Vielen Dank für die schnelle Antwort!
Installiert war LibreOffice-still
Habe alles deinstalliert und mit pacman LibreOffice-Fresh sowie LibreOffice-Fresh-de installiert.
Bei der Installation viele Fehlermeldungen (Datei konnte nicht heruntergeladen werden) aber eine Installation ist erfolgt.
Beim Starten allerdings der gleiche Fehler wie vorher:
/usr/LibreOffice/Programm/soffice.bin: error while loading shared libraries: libicuuc.so.65:
cannot open shared object file: No such file or Directory

Ich hoffe, dass irgendwann wieder ein Treffen möglich sein wird und ich den PC mitbringen kann.

Erst einmal Danke für Deine Mühen,doch Ferndiagnosen sind nicht so einfach.

Helmut
Gespeichert
Andreas
Administrator
*****

Offline

Einträge: 779



Linux von Innen

Profil anzeigen
Re:Installation
« Antwort #5 am: 27. April 2020, 14:54:47 »

Die vielen Fehlermeldungen kommen von veralteten Spiegelservern. Umn die fehlende Bibliothek kümmere ich mich - da muss mal bei einem Update irgendwas mittendrin abgebrochen sein und dadurch ist ein Paket (aber welches?) fehlerhaft. Schau morgen mal hier rein - dann findest Du die Lösung.

LG
Andreas
Gespeichert

Wissen ist das einzige Gut, das mehr wird, wenn man es teilt - wenn es Menschen gibt, die es weitergeben, und es Menschen gibt, die bereit sind, dieses Geschenk auch unter eigenem Einsatz anzunehmen.


Freiheit zu erkämpfen reicht nicht. Man muss sie auch verteidigen.
Andreas
Administrator
*****

Offline

Einträge: 779



Linux von Innen

Profil anzeigen
Re:Installation
« Antwort #6 am: 27. April 2020, 15:49:21 »

Dir fehlt das Paket icu. Das ist schon in der Standardinstallation enthalten - hier muss also irgendwann mal was schief gelaufen sein.

Du kannst es installieren mit

sudo pacman -S icu

Und Du solltest deine Spiegelserverliste mal aktualisieren. Ich mache das immer mit dem Programm fetchmirrors. Das ist nicht in der Standardinstallation enthalten. Du kannst es installieren mit

sudo pacman -S fetchmirrors

Danach rufst Du es auf mit

sudo fetchmirrors

und folgst den Anweisungen - dann hast Du aktuelle Spiegelserver und keine Downloadprobleme von Paketen.

LG
Andreas
Gespeichert

Wissen ist das einzige Gut, das mehr wird, wenn man es teilt - wenn es Menschen gibt, die es weitergeben, und es Menschen gibt, die bereit sind, dieses Geschenk auch unter eigenem Einsatz anzunehmen.


Freiheit zu erkämpfen reicht nicht. Man muss sie auch verteidigen.
helinux
Newbie
*

Offline

Einträge: 24



Ich liebe dieses Forum!

Profil anzeigen
Re:Installation
« Antwort #7 am: 28. April 2020, 10:15:23 »

Hallo Andreas,
eine so schnelle Antwort hatte ich nicht erwartet.
Wie beschrieben, habe ich "icu" installiert, wieder mit vielen Download-Fehlern.

Danach fetchmirrors wie angegeben, bricht mit Fehlermeldung an, fetchmirrors nicht gefunden.

Dachte mir, PC neu starten, vielleicht bringt das was.

Aber: Linux startet nicht mehr (oder nicht vollständig), nur ein blinkender Cursor am oberen linken Bildschirmrand, keine Eingabe möglich.

Ich glaube, arch-Linux sollte neu installiert werden oder kann man noch was machen?

Nur schade, dass keine Treffen mehr sind.

Also doch wieder zurück zu Windows, wo ich in 30 Jahren nie solche Probleme hatte, denn was nützt mir Linux, wenn es nicht läuft?

Gruß Helmut

Gespeichert
Chris
Full Member
***

Offline

Einträge: 158



Okay, wer hat meine Kekse gegessen?

Profil anzeigen eMail
Re:Installation
« Antwort #8 am: 28. April 2020, 16:11:44 »

Moin Helmut,

ich muss mal eben etwas loswerden. Danach komme ich zu deinem Problem und was du prüfen könntest. Wenn das klappt, hast du noch alle Optionen zur Verfügung. Ich werde es mit einem Balken trennen. So musst du nicht unbedingt lesen, was ich zuerst schreibe. Es hat nicht wirklich was mit deinem Problem an sich zu tun ...




Erstmal ein kleiner Rant (sorry dafür)

Zitat von: helinux am 28. April 2020, 10:15:23
Also doch wieder zurück zu Windows, wo ich in 30 Jahren nie solche Probleme hatte, denn was nützt mir Linux, wenn es nicht läuft?

Naja, ganz so einfach ist der Vergleich nicht. Ich kann dir gefühlt 30+ Fälle melden (alleine in den letzten 2-3 Jahren), in denen ich weit mehr Probleme und Fehler mit Windows erlebt habe als mit jeder Linux Distro die ich je ausprobiert habe. Und da war sogar ein perfekt funktionierendes Windows bereits drauf.
Aber wie Andreas ja schon sagte, hätte icu bereits Teil deines Systems sein sollen. Hier lag also von Anfang an etwas im Argen. Das wäre bei Windows genauso nach hinten losgegangen - wahrscheinlich hättest du nicht einmal das nächste Update überlebt.

Nun könntest du einwenden: "Hab ich jetzt auch nicht". Aber im Gegensatz zu Windows hat man bei Linux meist noch die Chance trotzdem noch etwas zu fixen - auch ohne dafür einen seperaten Datenträger mit einer lauffähigen Version parat zu haben.
Ich kann dir das aus eigener Erfahrung erzählen, dass mein Kubuntu nach einem dummen Fehler meinerseits nicht mehr booten wollte. Also habe ich beim Start die erweiterte Startoption genommen. Kubuntu wurde dann mit dem nötigsten gestartet und ich konnte mich als root anmelden.
Hier konnte ich dann meine Probleme beheben.

Wenn ich so ein Problem mit Windows habe, kann ich nur mein Handtuch werfen und mich an meine Kollegen wenden. Die dürfen dann so lange auf irgendwelche Tasten hauen (zumindest sieht das für mich so aus), bis irgendetwas klappt.

Ich habe die Ehre, in einem Systemhaus zu arbeiten. Dort sehe ich viele PCs. Die meisten mit Windows. Und glaub mir, die haben ständig Probleme ...




Du sagtest, du hast einen blinkenden Cursor. Nun weiß ich nicht, ob EndevourOS plymouth installiert um seine Ausgaben zu unterbinden. Du könntest aber Folgendes probieren: Drück mal STRG+ALT+F2.
Linux hat mehrere TTY (TeleTYpewriter). Zur Anzeige deiner Desktopumgebung kommt dabei meist noch der sogenannte X-Server zum Einsatz. Dieser belegt einer deiner TTY (meist 1 oder 7). Startet der nicht richtig, kann es manchmal schon reichen, zu einem anderen TTY zu wechseln.

Das kann man mit STRG+ALT+F<Nummer des TTY> erreichen. Du wirst dann mit einem eher trockenem Login begrüßt. Dort kannst du dich jedoch normal einloggen und es so benutzen als wäre es ein Terminal, dass du geöffnet hast.

Übrigens kannst du mit den TTYs mehrere Benutzer einloggen und eingeloggt haben. Und das schon seit Ewigkeiten. Windows hatte da lange Zeit das Nachsehen. Just saying...

Gruß
Chris
Gespeichert

Der einzig sichere Computer der Welt ist ausgestöpselt, in einem Tresor verstaut und auf dem Meeresboden.
Und nur eine Person kennt die Kombination zum Tresor.
Und diese ist tot.
[Bruce Schneier]
helinux
Newbie
*

Offline

Einträge: 24



Ich liebe dieses Forum!

Profil anzeigen
Re:Installation
« Antwort #9 am: 29. April 2020, 09:07:12 »

Hallo Chris,
vielen Dank für Deinen Hinweis. Mit Strg+Alt+F2 komme ich in eine Umgebung, ähnlich dem Terminal. Befehle kann ich eingeben.

Aber was nützt mir das? Ohne grafische Oberfläche ist man ja ziemlich hilflos, weil ich die Befehle für die Programme bis auf wenige nicht kenne. Eigentlich sollte ich Arch-Linux starten, aber wie?

Benutzt habe ich sonst den Browser Firefox, der installiert war. Wie kann ich ihn im Terminal starten? Und bin ich überhaupt mit dem Internet verbunden?

Seit einem halben Jahr versuche ich nun Programme zu installieren. Mit viel Mühe ist mir das bei Hibiscus und Thunderbird gelungen. Dass man sich einarbeiten muss, ist ja schön und gut, aber langsam bin ich äußerst frustriert, dass nur Misserfolge zu verzeichnen sind und ich Linux zur Zeit nicht nutzen kann.

Ich bin der Ansicht, Arch-Linux sollte neu installiert werden. Alles andere macht wohl keinen Sinn mehr. Kann ich die Installation einfach noch einmal ausführen und was wird aus meinen Daten? Wie kann ich diese sichern?

Gruß Helmut
Gespeichert
Andreas
Administrator
*****

Offline

Einträge: 779



Linux von Innen

Profil anzeigen
Re:Installation
« Antwort #10 am: 29. April 2020, 12:09:59 »

Neuinstallationen sind eigentlich was für Windows-Nutzer. Ich habe seit 20 Jahren nicht mehr neu installiert (es sei denn, ich habe die Distribution gewechselt. Hier mein "Werdegang":
1999-2004: SuSE Linux
2005-2009: Ubuntu Linux
2010-2014: Debian
2015-2016: LMDE (Linux Mint Debian Edition)
2017-2019: Siduction
seit 2019: Arch Linux basiert (zuerst Antergos, dann EndeavourOS)

Daten retten ist ein Kinderspiel - wenn man sich mit Linux auskennt. Ohne Kenntnisse ist es eine schier unüberwindliche Hürde. Also: lieber System reparieren als Neuinstallieren. Ich denke, Du "landest" nur im falschen Terminal. Wenn der blinkende Cursor da ist: probiere mal ALT-CTRL-1 oder ALT-CTRL-7

LG
Andreas
Gespeichert

Wissen ist das einzige Gut, das mehr wird, wenn man es teilt - wenn es Menschen gibt, die es weitergeben, und es Menschen gibt, die bereit sind, dieses Geschenk auch unter eigenem Einsatz anzunehmen.


Freiheit zu erkämpfen reicht nicht. Man muss sie auch verteidigen.
helinux
Newbie
*

Offline

Einträge: 24



Ich liebe dieses Forum!

Profil anzeigen
Re:Installation
« Antwort #11 am: 29. April 2020, 14:31:37 »

Hallo Andreas,

ALT-CTRL-1 oder -7 tut sich nichts.

Beim Start ist der erste Bildschirm da (blau gekachelt) mit

EndevourOS Linux, with Linux Linux
EndevourOS Linux, with Linux Linux (fallback initramfs)
Memory Tester

unten pfeile für Richtungstasten

egal was ich auswähle, danach der schwarze Bildschirm mit blinkendem Cursor.

Nur mit CTRL-ALT-F2 komme ich zu einer Eingabe wie gestern beschrieben.

Wie soll ich als Anfänger das reparieren?

Helmut
Gespeichert
Andreas
Administrator
*****

Offline

Einträge: 779



Linux von Innen

Profil anzeigen
Re:Installation
« Antwort #12 am: 29. April 2020, 14:50:22 »

Als Anfänger gar nicht. Eine Neuinstallation (mit dem neuesten Installationsimage vom April - am Besten noch ein paar Tage warten, das Image vom 11.04. hatte noch ein paar Bugs und wird gerade gefixt) wird dein Problem lösen. Ich denke bei irgendeiner Nachinstallation oder einem Update ist irgendwas schief gelaufen - wenn das die Installation aus der VHS war war die Installation an sich ok (da war ich ja dabei). Was bleibt ist die Datensicherung. Die kann man auf der Konsole durchführen - aber dazu braucht man scho einige Konsolenkenntnisse. Sind denn Sachen drauf die Du unbedingt retten musst? Dann müsstest Du das Gerät entweder zu jemandem bringen der sich damit auskennt oder bis zum nächsten Treffen warten. Das kann aber noch Monate dauern... Auf jeden Fall ist as von Dir beschriebene Verhalten untypisch und ein absoluter Einzelfall, den es immer und überall gibt.

LG
Andreas
Gespeichert

Wissen ist das einzige Gut, das mehr wird, wenn man es teilt - wenn es Menschen gibt, die es weitergeben, und es Menschen gibt, die bereit sind, dieses Geschenk auch unter eigenem Einsatz anzunehmen.


Freiheit zu erkämpfen reicht nicht. Man muss sie auch verteidigen.
Andreas
Administrator
*****

Offline

Einträge: 779



Linux von Innen

Profil anzeigen
Re:Installation
« Antwort #13 am: 29. April 2020, 15:14:44 »

Nachtrag:
Natürlich will ich die Info nicht vorenthalten wie ich hier vorgehen würde.
  • eine Verbindung mit dem Router per LAN-Kabel herstellen
  • das Gerät booten
  • dann mit ALT+CTRL+2 auf Konsole zwei wechseln
  • als "root" einloggen
  • mit pacman -S fetchmirrors das Paket "fetchmirrors" nachinstallieren
  • dann fetchmirrors ausführen (den Anweisungen folgen)
  • dann mit pacman -Syu ein Komplettupdate durchführen - lesen, ob irgendwelche Fehlermeldungen auftauchen
  • wenn alles erfolgreich war, mit reboot neu booten
...und schauen ob sich was verändert hat...
Ein Feedback hier hilft Dir dann in jedem Fall weiter.

LG
Andreas
Gespeichert

Wissen ist das einzige Gut, das mehr wird, wenn man es teilt - wenn es Menschen gibt, die es weitergeben, und es Menschen gibt, die bereit sind, dieses Geschenk auch unter eigenem Einsatz anzunehmen.


Freiheit zu erkämpfen reicht nicht. Man muss sie auch verteidigen.
helinux
Newbie
*

Offline

Einträge: 24



Ich liebe dieses Forum!

Profil anzeigen
Re:Installation
« Antwort #14 am: 30. April 2020, 17:36:29 »

Hallo Andreas,
meine Versuche sind leider nicht erfolgreich.
PC mit Netwerkkabel verbunden, dann booten
Cursor auf schwarzem Bildschirm
Mit LT+CTRL+2 ergibt sich keine Reaktion
Mit ALT+CTRL+F2 komme ich auf eine Befehlsebene, wo ich dann bin, weiß ich allerdings nicht
Danach als root angemeldet, geht
Dann pacman -S fetchmirrors
Fehlermeldung: Ziel nicht gefunden: fetchmirrors

Das könnte daran liegen, dass keine Verbindung mit dem Internet besteht.

Also keine Veränderung.
Wie kann ich prüfen, ob Verbindung zum Internet besteht?

Gruß Helmut
Gespeichert
Seiten: [1] 2 3 nach oben Drucken 
Diskussions- und Newsboard der Linux Interessen Gruppe Suletuxe  |  allgemeine Kategorie  |  Installation & Einrichtung  |  Thema: Installation « zurück vorwärts »
Gehe zu: 


Login mit Username, Passwort und Session Länge

 Es wird die Verwendung "Blink"-basierter Browser und mindestens 1024x768 Pixel Bildschirmauflösung
für die beste Darstellung empfohlen
 
freie Software für freie Menschen!
Powered by MySQL Powered by PHP Diskussions- und Newsboard der Linux Interessen Gruppe Suletuxe | Powered by YaBB SE
© 2001-2004, YaBB SE Dev Team. All Rights Reserved.
- modified by Andreas Richter (DF8OE)
Valid XHTML 1.0! Valid CSS!