logo

Suletuxe.de
Linux - Nutzer
helfen
Linux - Nutzern

Willkommen, Gast. Bitte Login oder Registrieren.
13. April 2021, 02:21:42
Übersicht Hilfe Suche Login Registrieren

Amateurfunk Sulingen
Diskussions- und Newsboard der Linux Interessen Gruppe Suletuxe  |  allgemeine Kategorie  |  Installation & Einrichtung  |  Thema: update aus Repositories fehlgeschalgen « zurück vorwärts »
Seiten: [1] nach unten Drucken
   Autor  Thema: update aus Repositories fehlgeschalgen  (Gelesen 333 mal)
daggi
Newbie
*

Offline

Einträge: 27



Ich liebe dieses Forum!

Profil anzeigen eMail
update aus Repositories fehlgeschalgen
« am: 07. Januar 2021, 10:40:59 »

Guten Morgen liebe Suletuxe

meine Problem :
Warnung: postgresql-9.6: Lokale Version (9.6.18-3) ist neuer als trinity (9.6.13-1)
:: python-pyqtwebengine durch extra/python-pyqt5-webengine ersetzen? [J/n]
:: python-sip durch extra/python-sip4 ersetzen? [J/n]
:: sip durch extra/sip4 ersetzen? [J/n]
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: Entfernen von sip verletzt Abhängigkeit 'sip', benötigt von python-pyqt4
:: Entfernen von sip verletzt Abhängigkeit 'sip', benötigt von python2-pyqt4
:: Starte vollständige Systemaktualisierung...
Warnung: postgresql-9.6: Lokale Version (9.6.18-3) ist neuer als trinity (9.6.13-1)
:: python-pyqtwebengine durch extra/python-pyqt5-webengine ersetzen? [J/n]
:: python-sip durch extra/python-sip4 ersetzen? [J/n]
:: sip durch extra/sip4 ersetzen? [J/n]
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: Entfernen von sip verletzt Abhängigkeit 'sip', benötigt von python-pyqt4
:: Entfernen von sip verletzt Abhängigkeit 'sip', benötigt von python2-pyqt4




Wenn ich ein Update mit yay starte, müssen dann alle Pakete ersetzt werden ?  also J antworten

Sind die Abhängigkeiten dann  " erledigt "  ?? -  Wenn ich  sip  ersetzte ,  obwohl es von python-pyqt4  benötigt wird ??
Kann mir jemand einen Tipp geben, damit ich das logisch nachvollziehen kann  ?  Danke

LG Daggi



Gespeichert

Wenn du immer nur das tust, was du schon kannst, wirst du immer nur das sein, was du schon bist. Versuch doch mal was Neues - und fang sofort damit an!
Andreas
Administrator
*****

Offline

Einträge: 798



Linux von Innen

Profil anzeigen
Re:update aus Repositories fehlgeschalgen
« Antwort #1 am: 07. Januar 2021, 18:47:17 »

Ich hatte das Problem vor ein paar Tagen auch. Ich habe dann

sudo pacman -Syu gestartet und mich durchgehangelt. Leider ist das schon einen Tag (und gefühlt 100 andere Linux-Aufgaben) her so dass ich nicht mehr wiedergeben kann wie ich geantwortet habe. Auf jeden Fall war alles logisch und schlüssig - es gab nichts wo ich auch nur eine Sekunde gezögert habe.

LG
Andreas
Gespeichert

Wissen ist das einzige Gut, das mehr wird, wenn man es teilt - wenn es Menschen gibt, die es weitergeben, und es Menschen gibt, die bereit sind, dieses Geschenk auch unter eigenem Einsatz anzunehmen.


Freiheit zu erkämpfen reicht nicht. Man muss sie auch verteidigen.
Andreas
Administrator
*****

Offline

Einträge: 798



Linux von Innen

Profil anzeigen
Re:update aus Repositories fehlgeschalgen
« Antwort #2 am: 08. Januar 2021, 09:58:33 »

Hallo Dagmar,

ich habe mal in meiner History gekramt. Es sind zwei Konflikte die zeitgleich aufgetreten sind. Einen alleine kann swupdate oft beheben - zwei gleichzeitig niemals (da habe ich absichtlich verhindert - zu groß ist die Gefahr dass man sich mit so einem Automaten alles zerschießt...)

Ich habe mal ein von Hand gebautes Paket von tclx in "unser" repo gelegt, das bei euch allen ja hoffentlich eingebunden ist (pb4a - bei Dir ist es das, Dagmar)

Schau mal ob das dein Problem gelöst hat.

LG
Andreas
« Letzte Änderung: 08. Januar 2021, 10:23:33 von Andreas » Gespeichert

Wissen ist das einzige Gut, das mehr wird, wenn man es teilt - wenn es Menschen gibt, die es weitergeben, und es Menschen gibt, die bereit sind, dieses Geschenk auch unter eigenem Einsatz anzunehmen.


Freiheit zu erkämpfen reicht nicht. Man muss sie auch verteidigen.
daggi
Newbie
*

Offline

Einträge: 27



Ich liebe dieses Forum!

Profil anzeigen eMail
Re:update aus Repositories fehlgeschalgen
« Antwort #3 am: 11. Januar 2021, 07:50:29 »

Übrigens :  update alles gut gelaufen -  Update mit pacman erfolgreich beendet...
mein Denkfehler war:  ich warte    auf die Anzeige:  Update erfolgreich usw.  das funktioniert ja  nur im swupdate  - 
Wie gut, dass wir ständig unseren Geist einschalten "können"  und dazulernen
LG  Daggi
« Letzte Änderung: 11. Januar 2021, 12:22:49 von daggi » Gespeichert

Wenn du immer nur das tust, was du schon kannst, wirst du immer nur das sein, was du schon bist. Versuch doch mal was Neues - und fang sofort damit an!
Seiten: [1] nach oben Drucken 
Diskussions- und Newsboard der Linux Interessen Gruppe Suletuxe  |  allgemeine Kategorie  |  Installation & Einrichtung  |  Thema: update aus Repositories fehlgeschalgen « zurück vorwärts »
Gehe zu: 


Login mit Username, Passwort und Session Länge

 Es wird die Verwendung "Blink"-basierter Browser und mindestens 1024x768 Pixel Bildschirmauflösung
für die beste Darstellung empfohlen
 
freie Software für freie Menschen!
Powered by MySQL Powered by PHP Diskussions- und Newsboard der Linux Interessen Gruppe Suletuxe | Powered by YaBB SE
© 2001-2004, YaBB SE Dev Team. All Rights Reserved.
- modified by Andreas Richter (DF8OE)
Valid XHTML 1.0! Valid CSS!